관리 메뉴

Dork's port

안드로이드 6.0 이상에서 Burp Suite 사용 본문

Linux

안드로이드 6.0 이상에서 Burp Suite 사용

Dork94 2020. 12. 13. 02:31

추후에 업데이트 할 것

 

안드로이드 6.0 이상에서는 시스템 인증서가 설치되지 않기 때문에 루팅이 필요함.

 

burp 인증서를 우선 안드로이드에 설치해둠 http://burp

 

루팅 후에 Magisk Module인 AlwaysUserCerts (github.com/NVISO-BE/MagiskTrustUserCerts/releases)를 설치

그 후 유저 영역에 설치된 burp 인증서를 system 영역의 인증서 영역으로 복사 (cp /data/misc/user/0/cacerts-added/9a5ba575.0 /system/etc/security/cacerts)

 

인증서 확인란에 PortSwigger가 보여지면 성공

 

cert validity too long 오류가 뜰경우 burp cert를 regenerating 해야한다. (다음 게시물 링크 걸기)

Reference : www.theburpsuite.com/2020/05/intercepting-android-application-https.html

0 Comments
댓글쓰기 폼